NullReferenceException for SolutionInfo

Jan 14, 2010 at 1:30 PM
Edited Jan 14, 2010 at 1:31 PM

Hello, 

your tool looks very promising! However, when I build, it will say in the output window:

 

Error 7 Error occured while executing build version increment.

System.NullReferenceException: Object reference not set to an instance of an object.

at BuildVersionIncrement.SolutionItem.get_BuildDependency()

at BuildVersionIncrement.VersionIncrementer.UpdateProject(SolutionItem solutionItem)

at BuildVersionIncrement.VersionIncrementer.ExecuteIncrement()

 

What could be the cause?

Context (not sure any of this matters): I'm running an english vs2008 sp1. I'm using the new 2.1.10012.2001 version.

My AssemblyInfo attribute is in a separate file called SolutionInfo, which exists at the solution level and is linked from all projects. 

I used the add-in settings to indicate the location of this file, both in solution and project configurations. I did set 'change AssemblyVersion' to true, also both on solution and on project level.

This strategy works so far (when i change the number it manually, it's changed in all of the assemblies), but can't get the add-in to work.I was hoping to get readable numbers rather than the "*" increment..

 

greets,

Maarten

Error 7 Error occured while executing build version increment.
System.NullReferenceException: Object reference not set to an instance of an object.
   at BuildVersionIncrement.SolutionItem.get_BuildDependency()
   at BuildVersionIncrement.VersionIncrementer.UpdateProject(SolutionItem solutionItem)
   at BuildVersionIncrement.VersionIncrementer.ExecuteIncreme