Using Build Version?

Dec 21, 2009 at 2:22 PM

I downloaded your add-in and installed it. I set it up in VS, but it throws a couple errors.

Do You have a quick example of how to implement this? I've looked through the discussions
and I don't see anything. Can I just create a seperate file with versioning?

Any help would be apperciated.

Thanks,
Don

Dec 22, 2009 at 12:26 PM
Edited Dec 22, 2009 at 12:28 PM

Hi Bobby,

I'll post what I have but this is really a lack of understanding how, where and why to apply the code.
That is why I asked if there was a working example that could be posted, hopefully to be used in a seperate file.

I've read through most of the discussions on this site and went to Yogesh's site as well.

Here is what I have:

<ProjectExtensions>
<VisualStudio>
<UserProperties BuildVersion_StartDate=
"2000/1/1" BuildVersion_BuildVersioningStyle="None.None.TimeStamp.Increment" BuildVersion_UpdateFileVersion="True" BuildVersion_UpdateAssemblyVersion="True" />
</VisualStudio></ProjectExtensions>

Here are the errors:

Error 7 Attribute specifier is not a complete statement. Use a line continuation to apply the attribute to the following statement. C:\Documents and Settings\Don\My Documents\Visual Studio 2008\Projects\Detail Prints\Assembly Info.vb 2 19 DetailPrintsDialog
Error 8 Attribute specifier is not a complete statement. Use a line continuation to apply the attribute to the following statement. C:\Documents and Settings\Don\My Documents\Visual Studio 2008\Projects\Detail Prints\Assembly Info.vb 3 16 DetailPrintsDialog
Error 9 '>' expected. C:\Documents and Settings\Don\My Documents\Visual Studio 2008\Projects\Detail Prints\Assembly Info.vb 4 21 DetailPrintsDialog
Error 10 Identifier expected. C:\Documents and Settings\Don\My Documents\Visual Studio 2008\Projects\Detail Prints\Assembly Info.vb 5 4 DetailPrintsDialog
Error 11 Identifier expected. C:\Documents and Settings\Don\My Documents\Visual Studio 2008\Projects\Detail Prints\Assembly Info.vb 6 2 DetailPrintsDialog

Thanks,
Don

 

Dec 22, 2009 at 1:47 PM

Ah, I feel like a dork! I found where this is and understand how it works now. Sorry for the confusion.

Thanks,
Don

Dec 22, 2009 at 4:04 PM

It was posted in one of the discussion threads, I wasn't aware that the Assembly Version that was being updated was on the properties page.
Maybe a screen shot on the home page of what is being updated would clear up future confusion. Thanks for providing this it is quite useful!

Don