Builds not incrementing in Visual Studio 2010

Jun 15, 2011 at 7:05 PM

I'm having trouble getting anything to increment in Visual Studio 2010.  I am using TFS for source control.

 

I have selected a single project within the solution.  I set the Update AssemblyVersion to TRUE and changed the Versioning Style to "None. None. Increment. TimeStamp".  When I make  change to the source code in this project and build it, the assembly version never changes.  I even tried specifying the Assembly.cs file.

Any ideas?

Jun 16, 2011 at 5:56 PM

So it magically worked today.  The only difference was a restart from yesterday.

 

Hopefully it keeps working as this is a great add-in.

Nov 21, 2011 at 11:42 AM
Edited Nov 21, 2011 at 11:42 AM

Using the 2.5 beta version (tryed 2.4 too) I found I had to change 'Increment before build' to false. So Version number in Project is always 1 behind, though it's no big issue when working with increment not Date or Time values.

BTW: I use this from today, so I did not wait for the magic of the restart on next day =)