This project is read-only.
2
Vote

System.FormatException

description

I have this error:
 
Error occured while reading BuildVersionIncrement settings from "XXX.vcxproj"
System.FormatException: String was not recognized as a valid Boolean.
at System.Boolean.Parse(String value)
at BuildVersionIncrement.SolutionItemIncrementSettings.Load()
 
The system is W7x64 (Catalan), VS2010 (English). any clue?.
 
Regards,

comments

kaczorck wrote Jul 3, 2013 at 2:12 PM

I have just the same issue. It is only on C++ project it does not happen on other attached in Solution .NET projects.

Error 3 Error occured while reading BuildVersionIncrement settings from "_____.vcxproj"
System.FormatException: String was not recognized as a valid Boolean.
at System.Boolean.Parse(String value)
at BuildVersionIncrement.SolutionItemIncrementSettings.Load()

If you have found solution for the issue please let me know.

Best Regards,

kaczorck wrote Jul 5, 2013 at 4:24 PM

Hey I've got it.
of some reason this BuildVersionIncrement Add-in have saved in vcxproj settings. All settings was with null values.
You yould edit xxxxx.vcxproj file it is common XML file.
the the end in <ProjectExtensions> .. <VisualStudio> you should edit <UserProperties....>
  <ProjectExtensions>
    <VisualStudio>
      <UserProperties BuildVersion_UseGlobalSettings="" BuildVersion_AssemblyInfoFilename="" BuildVersion_StartDate="" BuildVersion_BuildVersioningStyle="" BuildVersion_UpdateFileVersion="" BuildVersion_UpdateAssemblyVersion="" />
    </VisualStudio>
  </ProjectExtensions>
Paste filled one: ex:
<ProjectExtensions>
    <VisualStudio>
      <UserProperties BuildVersion_UseGlobalSettings="False" BuildVersion_AssemblyInfoFilename="AssemblyInfo.cpp" BuildVersion_StartDate="2012/8/6" BuildVersion_BuildVersioningStyle="DeltaBaseYear.MonthStamp.Increment.TimeStamp" BuildVersion_UpdateFileVersion="False" BuildVersion_UpdateAssemblyVersion="True" />
    </VisualStudio>
  </ProjectExtensions>
be aware not to set BuildVersion_UpdateFileVersion="False" in standard VC++ projects common AssemblyInfo.cpp does not have such variable. That might caused all the issues.

wrote May 29, 2014 at 6:37 AM